PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)


ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)

Сообщений 511 страница 531 из 531

511

Stas556 написал(а):

Олег, я не понимаю это выражение - (т.е. "любой .pma к любому .pmg" должен подходить в игре). Каким образом это делается? Как я должен "привязать" pma к pmg? Они по сути и так должны быть привязаны... Или надо какую то галочку где то ставить?  :blush: Мне так и не удалось настроить стирание дождя в двух моих модах. Хотя с остальными модами проблем с этим нет, они и сделаны аналогично этим двум. Я предполагаю, что игра просто не видит думис дождя... Я уже все перепробовал, даже ставил дефолтные дворники вместо своих.

.pma к .pmg никак не привязаны, игра заргужает и отрисовывает модель из pmg и применяет к ней анимацию из (нескольких) pma. В обновлении 1.35 в файлах появилась идентификация в .pma файлах, которую игра сверяет с .pmg (подходит / не подходит). раньше этого не было и игре можно было скормить любую .pma для любого .pmg. Я так понимаю, сделали эту проверку на случай если в обновлении или в моде меняется иерархия модели, старые .pma могли поломать анимацией модель (начать анимировать не те объекты). сейчас игра определит сама эту проблему. Вот, вкратце, как я вижу изменения и их суть. по большому счету, для модели надо сделать экспорт anim.pmd/pmg и экспорт её .pma файлов.

а вот что не так с дождем я сказать не могу. прежде чем с этой траблой биться, надо взять дефолтный трак и его anim.pmd прогнать импорт-экспортом без изменений и положить в мод. если с ним перестанет работать стирание капель, то значит экспорт что-то поломал. возможно в этом тесте придется и файлы .pma прогнать импорт-экспортом.

просто я бы не стал ковырять мод в поисках проблемы, если проблема воспроизводится на дефолтном траке импортом-экспортом. если же на дефолте всё работает, то тогда действительно надо копать уже в своём моде.

0

512

Jazzycat, можно скриншот и стрелочкой (или описанием) указать, где именно этот материал (как выглядит в игре) ?

0

513

ZModeler3 написал(а):

.pma к .pmg никак не привязаны, игра заргужает и отрисовывает модель из pmg и применяет к ней анимацию из (нескольких) pma. В обновлении 1.35 в файлах появилась идентификация в .pma файлах, которую игра сверяет с .pmg (подходит / не подходит). раньше этого не было и игре можно было скормить любую .pma для любого .pmg. Я так понимаю, сделали эту проверку на случай если в обновлении или в моде меняется иерархия модели, старые .pma могли поломать анимацией модель (начать анимировать не те объекты). сейчас игра определит сама эту проблему. Вот, вкратце, как я вижу изменения и их суть. по большому счету, для модели надо сделать экспорт anim.pmd/pmg и экспорт её .pma файлов.

а вот что не так с дождем я сказать не могу. прежде чем с этой траблой биться, надо взять дефолтный трак и его anim.pmd прогнать импорт-экспортом без изменений и положить в мод. если с ним перестанет работать стирание капель, то значит экспорт что-то поломал. возможно в этом тесте придется и файлы .pma прогнать импорт-экспортом.

просто я бы не стал ковырять мод в поисках проблемы, если проблема воспроизводится на дефолтном траке импортом-экспортом. если же на дефолте всё работает, то тогда действительно надо копать уже в своём моде.

Олег, я все "pma" пересохранял и аниму переэкспортировал. Повторюсь, это происходит только с двумя моими модами. Остальные моды работают без проблем. И делаются моды всегда по одной и той же технологии. Проблему решить не могу... Такое впечатление, что игра не видит думис. Сегодня буквально проблема была с экспортом (это к этим модам не имеет отношения) Проблема в том, что при экспорте заноза никак не хотела переименовывать пару думисов в мое название "Zfigure_210_2" и "Zfigure_211_2". Заноза сама при экспорте убирала двойки и в итоге получалось при импорте так "Zfigure_210_" и "Zfigure_211_" В итоге пришлось переименовать в другое название "Zfigure_2102" и "Zfigure_2112", тогда получилось. Как это объяснить? Это просто мистика.

0

514

Stas556 написал(а):

аноза сама при экспорте убирала двойки и в итоге получалось при импорте так "Zfigure_210_" и "Zfigure_211_"

Извиняюсь, что вмешиваюсь, но в данном случае проблема в длине названия думмиса. В некоторых случаях игра не поддерживает количество символов в имени больше 12-ти.

+1

515

vad&k написал(а):

Извиняюсь, что вмешиваюсь, но в данном случае проблема в длине названия думмиса. В некоторых случаях игра не поддерживает количество символов в имени больше 12-ти.

С такой же длинной названием в этой модели есть другие думисы. Однако они нормально экспортировались.

0

516

имена объектов пакуются в числовые идентификаторы. превышение доспустимого числа символов может дать неверный идентификатор и игра его не поймёт. так-что да, обязательно проверь ре-импортом, сохранились ли названия объектов и всех дамми.

0

517

Stas556 написал(а):

Однако они нормально экспортировались.

"это не ваша заслуга, а наша недоработка." (с)  :D

0

518

ZModeler3
Это материал от светоотражающей полоски на прицепе. Раньше она делалась двумя одинаковыми моделями с разными материалами - dif.spec и reflective. Сейчас одной моделью с одним материалом.

0

519

Продолжение темы про дворники, не стирание капель. Вот такой лог пишет игра:
(<ERROR> [core_interior_glass] Non-continual (scissors like) movement detected for wiper with center bone: 'joint23', check wipers animation in model: '/vehicle/truck/corona_fox/interior/anim.pmd'!
<ERROR> [core_interior_glass] Non-continual (scissors like) movement detected for wiper with center bone: 'joint24', check wipers animation in model: '/vehicle/truck/corona_fox/interior/anim.pmd'!

В чем проблема, что не так?

скриншот: https://yadi.sk/i/KN1kSZZuUCExig

Отредактировано Stas556 (2019-06-28 17:15:58)

0

520

https://forum.scssoft.com/viewtopic.php … p;t=274468

А есть возможность проверить анимацию (anim.pmd) и wipers.pma на оригинальной модели путём импорта-экспорта? не ломается ли анима, не появляется ли ошибка?

похоже, что анимацию игра подхватывает для лезвий дворников и не понимает, что лезвия двигаются прикрепленными к поводкам дворников..

Edit:
Пардон, вижу:

Stas556 написал(а):

Повторюсь, это происходит только с двумя моими модами. Остальные моды работают без проблем.


но вот скорее всего в моде или с иерархией проблема или действительно анимация игре не нравится. В анимации дворников для точек "центр дворника" тоже дорожки/трэки анимации сделал или только для поводков?

0

521

ZModeler3 написал(а):

но вот скорее всего в моде или с иерархией проблема или действительно анимация игре не нравится. В анимации дворников для точек "центр дворника" тоже дорожки/трэки анимации сделал или только для поводков?

С иерархией проблем нет, даже все ид правильные без пропусков (не без зубая). Повторюсь, эта анима с дворниками прекрасно работала и на предыдущих версиях. Менял думисы и естественно переписывал с ними треки. Думис на стекле тоже менял. Попробую по твоему совету поставить эту аниму целиком на дефолт, потом отпишусь... Но честно говоря не вижу смысла в этом. Ведь я ставил дефолтные дворники на эту модель и без результата...

0

522

Парни, всем привет!
Может кто подскажет!?
как быть с этой ошибкой?

Код:
00:01:42.091 : <ERROR> [dx11] Unable to map attribute (v.tex_coord_2)
00:01:42.091 : <ERROR> [dx11] Failed to create vertex input layout!


Дима (axelrol), выше спросил, но ответа я так и не нашел))

0

523

"v.tex_coord_2" Это на самом деле UV#3. В материале который собралась использовать игра ожидается третий канал мэппинга, а в геометрии в файле этого канала не оказалось. Наиболее частая причина - на момент экспорта ZModeler не смог определить, что материал будет использовать три канала мэппинга и выгрузил два (или один). Самый простой способ заставить ZModeler выгрузить три канала, это поставить на вкладке DETAIL2 "Manual UV#3" в опции "Source UV Mapping". Самое проблемное - это определить материал, который давет такую ошибку, но, как правило, это материал truckpaint.

Еще важный момент - некоторые делают аксессуары, а материалы под них делают в зависимости от вариантов (простой пластик, хром, покраска в цвет кузова). файлы материалов можно вручную в материале указать, но выгрузка может оказаться нерабочей именно из-за причины указанной в первом абзаце. Например, материал настроен под "хром", а вариант с "truckpaint" прописан вручную в Material States. на выгрузке геометрия пойдет в соответствии с текущими настройками материала (настройки под хром), скорее всего с одним или двумя каналами UV. и как только игра попробует включить вариант, где на аксессуар натягивается раскраска truckpaint - и обнаруживается, что в геометрии нет третьего канала (ZModeler понятия не имел, что он понадобится).

Ну вот как-то так.

0

524

ZModeler3 написал(а):

(ZModeler понятия не имел, что он понадобится)

Спасибо! (гемора прибавилось)

Вообще планируется, как-то это сама программа меняла? или это не является частью программы? (или я не так что-то понял)

0

525

ZModeler3, подскажите пожалуйста, почему не импортируются никакие файлы в zmodeler, программа активирована и никаких ошибок при импорте не показывает, работает только открытие z3d файлов.

0

526

не импортирует только .pmd/pmg? или .obj .3ds тоже не грузятся?

похоже, что лицензионный ключ был получен после запуска программы, а должен быть установлен на момент запуска программы (после получения ключа программа перезапускается и окно с лицензией само не должно открываться). программу запускать под администратором - возможно, она просто не может сохранить ключ на диск. папку с программой по возможности переместить на диск D:

0

527

ZModeler3 написал(а):

не импортирует только .pmd/pmg? или .obj .3ds

Олег, не грузятся ни pmd, ни obj, ни 3ds, программа у меня стоит на втором жёстком, который без системы, в прошлые разы стояла так же и всё работало. Попрбовал устанавливать и на тот и на другой, и от администратора запускать, всё безрезультатно.Вот скрин с лицензией.
http://sh.uploads.ru/t/oPZUI.jpg

0

528

Удалите оба файла CodeLib в папке Shared, запустите программу - она должна скачать обновления. потом перезапустите и поставьте лицензионный ключ. такая проблема была, но она была исправлена в феврале или марте, возможно не хватает обновления. как вариант, попробуйте версию программы с сайта активировать ключем - она работает?

0

529

ZModeler3 написал(а):

возможно не хватает обновления

Действительно проблема была в обновлении, сейчас всё работает, спасибо за помощь.

0

530

Итак, возникла проблема (уже не знаю как решить её - запарился). Имеется заноза 3.2.0 x64 (последний билд). Имеется трак, который до текущего момента работал без проблем, пока не возникла необходимость в очередной раз добавить тюнинг на кабину. При импорте/открытии в занозе он выглядит так:

http://images.vfl.ru/ii/1569746646/0f68fb1e/28010927_m.jpg

Все части кабины имеют 4 UV канала (для примера привожу одну):

http://images.vfl.ru/ii/1569746647/5907f673/28010928_m.jpg

Вот как выглядят свойства материала truckpaint:

http://images.vfl.ru/ii/1569746647/721ab996/28010929_m.jpg

Сам материал взят из базы, изменены только пути к тестурам (двум) тк у меня текстуры в отдельной папке:

http://images.vfl.ru/ii/1569746647/4aa4cfff/28010930_m.jpg

Что имеем в игре после экспорта:

http://images.vfl.ru/ii/1569746647/9ada2d5e/28010931_m.jpg

Слетают причём не все покраски (например, Classic Paintjobs Pack слетают все). Обратите внимание, что на спойлере кусок не слетает, ибо спойлер я ещё не открывал и не экспортировал. Пробовал ставить в занозе вручную manual uv3 - нифига не канает. Куда копать уже не знаю.

P.S. Ошибок в логе про координаты UV нет. Вообще чисто.

P.P.S. Также пробовал копировать мапинг с третьего канала на второй, но в таком случае слетают уже те покраски, что используют второй канал, а UV3 становится нормальным. В общем, явно заноза при экспорте "убивает" третий канал. Олег, может с фильтром что то?

Отредактировано axelrol (2019-09-29 14:11:23)

0

531

Upd. После сегодняшнего обновления всё исправлено. Олег спасибо!

0


Вы здесь » PlayTruckSims: Грузовые симуляторы, Дальнобойщики, Euro Truck Simulator 2, American Truck Simulator » ZModeler » ZModeler3: вопросы, ответы, пожелания, помощь в освоении (часть 4/4)